Scheduled for April 18, 2025 at 7:45 PM – 11:45 AM
Affects
Website (Billing/Control)
Under maintenance from 7:45 PM to 11:45 AM
Billing
Under maintenance from 7:45 PM to 11:45 AM
Tenant Controller
Under maintenance from 7:45 PM to 11:45 AM
VPS Control Panel (VirtFusion)
Under maintenance from 7:45 PM to 11:45 AM
Lagless Panel
Under maintenance from 7:45 PM to 11:45 AM
Support System
Under maintenance from 7:45 PM to 11:45 AM
Updates
In progress
April 18, 2025 at 7:45 PM
In progress
April 18, 2025 at 7:45 PM
Maintenance is now in progress
Update
April 18, 2025 at 7:45 PM
Planned
April 18, 2025 at 7:45 PM
This maintenance has been pushed back 1 hour.
Update
April 18, 2025 at 7:00 PM
Planned
April 18, 2025 at 7:00 PM
Elcro will be performing scheduled maintenance at our Dallas Data Center location on Friday, April 18th, 2025, between 1:00PM CDT to 6PM CDT. During this time, we will be upgrading our top-of-rack switches to improve overall network performance and scalability.
While the maintenance window spans several hours, downtime is expected to be minimal as we will be upgrading one section at a time. Some customers may experience brief interruptions in connectivity or increased latency, but services will automatically resume as each upgrade completes.
We appreciate your understanding and will be closely monitoring the network throughout the process to ensure a smooth transition.